OC3D Forums

OC3D Forums (https://forum.overclock3d.net/index.php)
-   Storage Mediums (https://forum.overclock3d.net/forumdisplay.php?f=27)
-   -   AMD SB950 RAID 0 is a pain in the boot sector (https://forum.overclock3d.net/showthread.php?t=76620)

hotrob 25-06-16 09:25 PM

AMD SB950 RAID 0 is a pain in the boot sector
 
So here I am, thinking to myself hey, the 850 EVO in my desktop is filling up. The 850 EVO in my laptop has tons of space. And I have another, smaller SSD just collecting dust. Why not take a trip on the wild side and give RAID 0 a whirl?

Laptop backup and migration went smoothly (thankfully... I put the entire thing back together before testing if the clone worked).

So then I clone the boot drive to a spare HDD, and just to be safe, copy an image of the drive to another hard drive (highly recommend Macrium reflect as an aside, going to get the full version if I can get this RAID working). Clone booted just fine, so I double check my drivers are up to date, and they appear to be.

So I look up how to build the RAID on the ASUS 970 Pro Gaming/Aura, and the UEFI RAID utility just doesn't work. Fine, no biggie, I've got my big boy pants on, I can use the legacy RAID utility. After some fiddling, I get my RAID built; 1000 gigs of speedy storage, all for me (and my room mate).

Boot up Windows 10, and it sees nothing. Disk management doesn't see the volume or even the drives.

Rebuild the RAID and try again. Nothing.

So I check my drivers all over again, and still nothing. I figure, okay, maybe a fresh install.

Go to install windows 8.1 from my install USB, and it sees nothing. So load the drivers off the disk into the utility. Still nothing.

So I load up Linux, and it sees the RAID volume immediately. Bingo says I. Clone the drive through Linux, windows will crash a couple times trying to boot, repair the install, load up some drivers during the repair, and then we're off to the races.

Nope.

Linux says the drive image is restored to the disk just fine, but when I go to boot off of it, all I get is the "no bootable whatever on this disk etc" message.

I'm thinking at this point, is this even a problem unique to Windows?

Go to install Mint 17.4, and whaddya know? When it gets to the final step, it says it can't finish the installation (with the helpful error message of "??? ???"). At this point, I've exhausted everything I can think of (yes, I even tried the Windows 7 32-bit RAID driver trick, apparently that won't fly in windows 8.1/10).

Can anyone else think of something that might help me out? Or is the RAID controller on AMD's SB950 effectively useless?

barnsley 26-06-16 11:51 AM

You'd be best looking at dedicated hardware for RAID. My older, albeit high end, AMD 'board worked ok but I'd not trust it with anything.

hotrob 26-06-16 07:15 PM

I agree that a dedicated raid controller would be ideal, but unfortunately, that's not in my budget right now.

I'm not super worried about data loss; I make pretty frequent backups, and if the absolute worst happens and all my hard drives explode, there's nothing super important on here (all my work stuff is backed up to an external drive and again to the cloud).

I like challenges, but I could just take the easy way out. I could just suck it up and have two discrete 500 gig drives, or pick up a cheap small SSD to load the OS on and stripe the two EVOs in windows to install my programs on.

But then again, if I wanted to take the easy way out, I'd buy a Mac ;)


All times are GMT. The time now is 11:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.