Go Back   OC3D Forums > [OC3D] General Forums > OC3D Reviews & Videos
Reply
 
Thread Tools Display Modes
 
  #1  
Old 24-11-16, 05:23 PM
tinytomlogan's Avatar
tinytomlogan tinytomlogan is offline
The Guvnor
 
Join Date: Dec 2007
Location: TTL Towers
Posts: 20,736
Samsung NVMe 960 M.2 Evo SSD Review



Just how much slower is the Evo SSD when compared to the Pro? Could it be a bargain buy?


Samsung NVMe 960 M.2 Evo SSD Review

__________________
If you recommend a product LINK THE REVIEW


Get along or run along. Your choice
Reply With Quote
  #2  
Old 25-11-16, 05:01 AM
TheF34RChannel's Avatar
TheF34RChannel TheF34RChannel is offline
OC3D Elite
 
Join Date: Mar 2011
Location: The Netherlands
Posts: 1,991
Very nice review! This one has been put on my list now, affordable and an improved over my regular SSD. Thanks Tom!
__________________
Asus Z370 Maximus X Hero | Intel Core i7-8700K 4.7GHz | Corsair H105 | G.Skill Trident Z 3333MHz CL16 16GB | Asus GTX 1080 Strix | EVGA SuperNOVA 850 P2 | Crucial MX200 500 GB | 760T | Acer XB270HU 1440p | Windows 10 Pro x64
Reply With Quote
  #3  
Old 25-11-16, 09:06 AM
Dicehunter's Avatar
Dicehunter Dicehunter is offline
Resident Newb
 
Join Date: Oct 2012
Location: BlondesVille
Posts: 12,638
Great review !

Gonna get the 1TB Evo for my birthday in January
__________________
=AMD Ryzen 2700X @ 4.20GHz 8C/16T - Asus ROG Crosshair VII Hero WiFi X470 AM4=
=Corsair Vengeance RGB 16GB 3600MHz 2x8GB - Corsair H150i Pro + 6 x Corsair HDRGB 120mm=
=Corsair Crystal 570X Red + 3 x Corsair HDRGB 120mm - Corsair Link Commander Pro=
=Asus ROG Strix Vega 64 @ 1600/1000 - Asus ROG Strix XG35VQ 35" Ultrawide 100Hz Freesync=
=Creative SoundBlaster X AE-5 - Beyerdynamic 770/990/1770/1990 - 250 Ohm=
=Asus ROG Spatha - Asus ROG Claymore "100%" Cherry MX Blue - Asus ROG Sheath=
=Steam - Dicehunter = Origin - Dicehunter = Uplay - DicehunterUPLAY=

Reply With Quote
  #4  
Old 25-11-16, 03:38 PM
BUnicutZza BUnicutZza is offline
Newbie
 
Join Date: Dec 2010
Posts: 4
B O O T I N G or installing fresh copy of Windows on this SSD as nr.1 drive? is it problematic when using M.2 port ? How about using the PCIe card adaptor with it ? Does the motherboard need some BIOS setup changes so it can boot/ install windows ?
Reply With Quote
  #5  
Old 25-11-16, 07:54 PM
Dawelio's Avatar
Dawelio Dawelio is offline
OC3D Elite
 
Join Date: Aug 2014
Location: Scandinavia
Posts: 4,399
Quote:
Originally Posted by BUnicutZza View Post
B O O T I N G or installing fresh copy of Windows on this SSD as nr.1 drive? is it problematic when using M.2 port ? How about using the PCIe card adaptor with it ? Does the motherboard need some BIOS setup changes so it can boot/ install windows ?
My 850 Pro detecs and works just like any other drive. And Windows installed like if it was any other drive. So should be fine and straight forward
Reply With Quote
  #6  
Old 26-11-16, 01:56 AM
NeverBackDown NeverBackDown is offline
AMD Enthusiast
 
Join Date: Dec 2012
Location: Middle-Earth
Posts: 15,051
Quote:
Originally Posted by Dicehunter View Post
Great review !

Gonna get the 1TB Evo for my birthday in January
That's a hella expensive birthday gift
Reply With Quote
  #7  
Old 26-11-16, 04:24 AM
Doomslayer Doomslayer is offline
OC3D Elite
 
Join Date: Apr 2014
Posts: 3,037
Quote:
Originally Posted by NeverBackDown View Post
That's a hella expensive birthday gift
You know what Dice is like, To the point now can't tell which one is worse Dice or Chrazey
Reply With Quote
  #8  
Old 26-11-16, 05:39 AM
Dawelio's Avatar
Dawelio Dawelio is offline
OC3D Elite
 
Join Date: Aug 2014
Location: Scandinavia
Posts: 4,399
Quote:
Originally Posted by King of Old School View Post
You know what Dice is like, To the point now can't tell which one is worse Dice or Chrazey
What the....? Where do I come in, in all of this?
Reply With Quote
  #9  
Old 30-12-16, 05:45 PM
dwatterworth dwatterworth is offline
Member
 
Join Date: Jun 2013
Location: Rhode Island, United States.
Posts: 201
Just dropped 2 of these (same 500gb model) in 2 new workstations for a customer. The absolute performance is monstrous, especially when pulling lots of data from multiple 3D/BIM models, some big and sloppy PDF files and a sprinkling of 2D cad all running on multiple monitors at once, is just mind blowing. Completely smashed the previous m.2 drive I used in a lower cost build, one of the intel 600p series and makes my own 840 pro feel downright geriatric.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 05:27 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.