Go Back   OC3D Forums > [OC3D] General Forums > OC3D News
Reply
 
Thread Tools Display Modes
 
  #1  
Old 30-11-08, 08:25 AM
WC Annihilus WC Annihilus is offline
OC3D Elite
 
Join Date: Oct 2005
Posts: 3,057
Send a message via AIM to WC Annihilus Send a message via MSN to WC Annihilus
Hiper launches new PSU: M1000 80PLUS Bronze certified!

"Hiper adds a 1000W PSU to their M power supply line"

Read on

__________________
Core i5 750 [email protected] under OCZ Vendetta 2

MSI P55-GD65

3x Kingston X25-V RAID0

2x Evga 9600GT SSC SLI

G.Skill Ripjaws 2x2GB DDR3-1600

Corsair VX550w, Ghettoed Antec Super Lanboy

Reply With Quote
  #2  
Old 30-11-08, 10:02 AM
Hassan Hassan is offline
OC3D Crew
 
Join Date: Jan 2008
Posts: 783
Any one have problems with Hiper.

(Just making sure that I can safely put this brand on my safelist)
__________________
A mod changed my signature because it was too big. Tutt-tutt
Reply With Quote
  #3  
Old 30-11-08, 01:00 PM
zak4994 zak4994 is offline
OC3D Elite
 
Join Date: Oct 2008
Location: London, United Kingdom
Posts: 3,053
Sounds to good to be true...
Reply With Quote
  #4  
Old 30-11-08, 05:34 PM
Nagaru Nagaru is offline
OC3D Elite
 
Join Date: May 2006
Posts: 1,272
Quote:
Originally Posted by name='Hassan'
Any one have problems with Hiper.

(Just making sure that I can safely put this brand on my safelist)
Yes in fact I bought 2 of their original modular supplies that were put into computers I built for friends. On both, the 5V standby supply died.
__________________

Reply With Quote
  #5  
Old 30-11-08, 05:56 PM
JN JN is offline
OC3D Elite
 
Join Date: Mar 2005
Posts: 13,678
Having not tested one personally I wouldn't like to give my professional opinion.

I really don't like their mesh casing though. The heat should be exhausted out the back of the PC case, not allowed to radiate around the case.
Reply With Quote
  #6  
Old 30-11-08, 09:46 PM
Bungral Bungral is offline
OC3D Elite
 
Join Date: May 2007
Posts: 4,387
I had a 580 Type R for a good few months and it worked faultlessly for me. All voltages at good levels. It's sitting in my Dads PC now still chugging away.
__________________
CPU: Intel Core i5 2500K @ 4700mhz - 47 x 100MHz Mobo: MSI P67A GD65 GPU: EVGA GTX 570 RAM: 2 x 4GB Mushkin LV 1.35v 1600MHz DDR3 HDD: 3 x 1TB Samsung Spinpoint F3's Case: CoolerMaster ATCS 840 - Custom House of Kolor paint job. PSU: Corsair HX750 Cooling: Custom WC - XSPC Delta V3, PA120.3, DDC Ultra with XSPC Res Top, 3/8" XSPC UV Green Tubing over 1/2" Barbs OS: Windows 7 Enterprise Edition 64-Bit
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 12:12 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.