Go Back   OC3D Forums > [OC3D] Hardware & Software > Networks & Security
Reply
 
Thread Tools Display Modes
 
  #1  
Old 26-01-10, 07:07 AM
siravarice's Avatar
siravarice siravarice is offline
OC3D Elite
 
Join Date: Oct 2009
Posts: 1,184
Internet really slow. Anyone else having this problem?

I'm with o2. Meant to get 6mb speeds but since yesterday it has been a MAXIMUM of 5kb/s. It's a joke. I don't know if they are upgrading the exchange or what, but a friend of mine down the road says he hasn't had any problems with internet speeds. It seems to load pages just as quick as it used to, and buffer things as quick as it used to, but downloading anything is ridiculously slow.

A phonecall to o2 is in order methinks.

__________________
AMD Phenom II x4 970*
16GB RAM*
GTX 460*

*Won at a Xmas party raffle.
Reply With Quote
  #2  
Old 26-01-10, 07:46 PM
zak4994 zak4994 is offline
OC3D Elite
 
Join Date: Oct 2008
Location: London, United Kingdom
Posts: 3,053
Maybe there is something wrong with the server you downloaded from. Try downloading from different websites?
Reply With Quote
  #3  
Old 26-01-10, 08:43 PM
jiffz jiffz is offline
OC3D Elite
 
Join Date: Sep 2005
Posts: 1,973
Are you talking about torrent downloads or downloading something direct from a site?
Reply With Quote
  #4  
Old 26-01-10, 11:24 PM
mrapoc mrapoc is offline
OC3D Elite
 
Join Date: Jul 2006
Location: Shropshire
Posts: 5,679
check your exchange on www.samknows.com
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 04:56 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.