Go Back   OC3D Forums > [OC3D] Customer Care Forums > Corsair Customer Care Forum
Reply
 
Thread Tools Display Modes
 
  #1  
Old 19-11-13, 02:22 PM
Gamepro105's Avatar
Gamepro105 Gamepro105 is offline
Advanced Member
 
Join Date: Dec 2012
Location: UK
Posts: 364
Send a message via Skype™ to Gamepro105
Question Corsair k90 keyboard firmware just crashes my computer?

Hello all as said in the title when i try and update the firmware it crashes the computer and then stops all the other peripherals from working they just flash on and off... i wouldn't be so worried but when the keyboard arrived yesterday my games appeared to be frame dropping even in dota! can any one help?

many thanks luke

__________________
My Build:
Corsair 600t | ASUS P8Z77-V LX | i5 3570K | H100i | XFX 7950 | Corsair VENGANCE PRO 8GB | Corsair AX860W | Western Digital Blue 1TB | Dual 200mm Mod|
Find it here:http://forum.overclock3d.net/showthread.php?t=50689
Reply With Quote
  #2  
Old 20-11-13, 01:11 AM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
Hi Luke,
Sorry to hear that. Where do you have the KB connected USB2.0 or 3.0? Best to have it plugged in 2.0 when flashing the FW.

Go into your windows processes and kill everything K90 related do the following steps:
Control Panel > Power Options > Change Plan Settings > Change Advanced Power Settings > USB Settings > USB selective suspend setting > Disabled
Then run the firmware update again.

Let me know if that helps.
Reply With Quote
  #3  
Old 20-11-13, 02:34 PM
Gamepro105's Avatar
Gamepro105 Gamepro105 is offline
Advanced Member
 
Join Date: Dec 2012
Location: UK
Posts: 364
Send a message via Skype™ to Gamepro105
Quote:
Originally Posted by Grey_beard View Post
Hi Luke,
Sorry to hear that. Where do you have the KB connected USB2.0 or 3.0? Best to have it plugged in 2.0 when flashing the FW.

Go into your windows processes and kill everything K90 related do the following steps:
Control Panel > Power Options > Change Plan Settings > Change Advanced Power Settings > USB Settings > USB selective suspend setting > Disabled
Then run the firmware update again.

Let me know if that helps.
I unplugged all of my other equipment and installed it it dident crash the computer when i installed it but i still get lag in games? i will try un-installing and re-installing via the way you said and retry also i noticed my sound controls don't work is there any reason for this?
__________________
My Build:
Corsair 600t | ASUS P8Z77-V LX | i5 3570K | H100i | XFX 7950 | Corsair VENGANCE PRO 8GB | Corsair AX860W | Western Digital Blue 1TB | Dual 200mm Mod|
Find it here:http://forum.overclock3d.net/showthread.php?t=50689
Reply With Quote
  #4  
Old 20-11-13, 11:00 PM
Gamepro105's Avatar
Gamepro105 Gamepro105 is offline
Advanced Member
 
Join Date: Dec 2012
Location: UK
Posts: 364
Send a message via Skype™ to Gamepro105
Quote:
Originally Posted by Grey_beard View Post
Hi Luke,
Sorry to hear that. Where do you have the KB connected USB2.0 or 3.0? Best to have it plugged in 2.0 when flashing the FW.

Go into your windows processes and kill everything K90 related do the following steps:
Control Panel > Power Options > Change Plan Settings > Change Advanced Power Settings > USB Settings > USB selective suspend setting > Disabled
Then run the firmware update again.

Let me know if that helps.
i can confirm i have done this and it did not work i also got a blue screen earlier from trying to use the mode keys?
__________________
My Build:
Corsair 600t | ASUS P8Z77-V LX | i5 3570K | H100i | XFX 7950 | Corsair VENGANCE PRO 8GB | Corsair AX860W | Western Digital Blue 1TB | Dual 200mm Mod|
Find it here:http://forum.overclock3d.net/showthread.php?t=50689
Reply With Quote
  #5  
Old 22-11-13, 06:56 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
If its causing the game to lag and if there is somehow a conflict with your audio driver then I would suggest that you try it on a different system and see if the issue is system dependent. I would like to think that this is hardware issue, like USB connector causing a short - I could be wrong though, but it's worth knowing.

btw, what OS are you using again?
Reply With Quote
  #6  
Old 22-11-13, 10:32 PM
Gamepro105's Avatar
Gamepro105 Gamepro105 is offline
Advanced Member
 
Join Date: Dec 2012
Location: UK
Posts: 364
Send a message via Skype™ to Gamepro105
Quote:
Originally Posted by Grey_beard View Post
If its causing the game to lag and if there is somehow a conflict with your audio driver then I would suggest that you try it on a different system and see if the issue is system dependent. I would like to think that this is hardware issue, like USB connector causing a short - I could be wrong though, but it's worth knowing.

btw, what OS are you using again?
Ok i will try it on a different system as soon as possible, i'm using windows 7.
__________________
My Build:
Corsair 600t | ASUS P8Z77-V LX | i5 3570K | H100i | XFX 7950 | Corsair VENGANCE PRO 8GB | Corsair AX860W | Western Digital Blue 1TB | Dual 200mm Mod|
Find it here:http://forum.overclock3d.net/showthread.php?t=50689
Reply With Quote
  #7  
Old 23-11-13, 01:16 AM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
Quote:
Originally Posted by Gamepro105 View Post
Ok i will try it on a different system as soon as possible, i'm using windows 7.
Alright, thanks. Please keep me posted.
Reply With Quote
  #8  
Old 23-11-13, 11:25 AM
Gamepro105's Avatar
Gamepro105 Gamepro105 is offline
Advanced Member
 
Join Date: Dec 2012
Location: UK
Posts: 364
Send a message via Skype™ to Gamepro105
Quote:
Originally Posted by Grey_beard View Post
Alright, thanks. Please keep me posted.
i have tried it in another system and it was fine, i then did the same test putting my mouse in that system and began to run into the same problem? it seems there is a conflict with my other peripheral?
__________________
My Build:
Corsair 600t | ASUS P8Z77-V LX | i5 3570K | H100i | XFX 7950 | Corsair VENGANCE PRO 8GB | Corsair AX860W | Western Digital Blue 1TB | Dual 200mm Mod|
Find it here:http://forum.overclock3d.net/showthread.php?t=50689
Reply With Quote
  #9  
Old 25-11-13, 05:52 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
Is it only specific with that mouse driver? because remember the K90 is using the default HID driver in Windows. So if the K90 works fine without that mouse, then it is very possible that the mouses' driver is the cause.
Reply With Quote
  #10  
Old 09-12-13, 01:26 AM
Gamepro105's Avatar
Gamepro105 Gamepro105 is offline
Advanced Member
 
Join Date: Dec 2012
Location: UK
Posts: 364
Send a message via Skype™ to Gamepro105
Quote:
Originally Posted by Grey_beard View Post
Is it only specific with that mouse driver? because remember the K90 is using the default HID driver in Windows. So if the K90 works fine without that mouse, then it is very possible that the mouses' driver is the cause.
i have tried updating the drivers and still had the same problem as much as when i don't use the mouse it works its also the other way round when i use a different keyboard with this mouse it works the only way i can get them to work together is by unplugging the mouse before it boots log in with only the keyboard wait 10 seconds plug the mouse in and it works fine, if i how ever just boot the computer with it in the keyboard light just flashes on and off and the computer wont get an input from either the keyboard,mouse or headset. are there any other ideas as i am still having this problem?

EDIT: I have done a full re-install of the system i installed all the rivers for the mouse and the keyboard and they worked fine together i then turned on windows updates and updated everything in there once they had installed the keyboard and mouse broke i think its one of the updates but what one would it be? and how can i fix it?
__________________
My Build:
Corsair 600t | ASUS P8Z77-V LX | i5 3570K | H100i | XFX 7950 | Corsair VENGANCE PRO 8GB | Corsair AX860W | Western Digital Blue 1TB | Dual 200mm Mod|
Find it here:http://forum.overclock3d.net/showthread.php?t=50689
Reply With Quote
Reply

Tags
firmware, k90, keyboard

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 05:51 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.