Go Back   OC3D Forums > [OC3D] Cooling Forum > Air Cooling
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-04-19, 03:05 PM
RobCharles1981 RobCharles1981 is offline
Member
 
Join Date: Apr 2010
Location: Swansea
Posts: 159
Corsair H60 2018 Installation Problems on AMD Ryzen

Hi All


I recent invested in the Corsair H60 (2018 Edition) Hydro Cooler for my AMD Ryzen Processor and my Motherboard is the MSI B4350 Gaming Motherboard.


I have been recently having trouble in getting this to install onto my CPU and I duly ordered and had the AM4 Retention Bracket via Amazon and I installed the Blots the with the Stock AMD Back Plate. Then I ran into a snag where I wasn't sure how to install the pump. So it's apparent there I need to add something onto the pump but what? - I looked on Youtube for ideas too.



I eventually after a fiddle got the pump to install using the AMD Clips on the Stock Bracket.


So why won't the pump install with AM4 retention bracket?
Any pointers would be great!


Many thanks!

__________________
AMD Ryzen 5 2600. MSI B450 Gaming Motherboard Corsair H60, Corsair Vengenance LPX 16gig DDR3

Corsair TX 750m PSU, AMD R9 390: Creative Soundblaster Z: Fractal R5 Case
Reply With Quote
  #2  
Old 06-04-19, 04:01 PM
Dawelio's Avatar
Dawelio Dawelio is online now
OC3D Elite
 
Join Date: Aug 2014
Location: Scandinavia
Posts: 4,819
I found this post on Reddit that seems to be digging into your exact problem, I didn’t personally fully read into the whole thread, but seems to be something worth reading. Hope it helps:

https://www.google.com/amp/s/amp.red...iw/h60_on_am4/
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 09:52 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.