Go Back   OC3D Forums > [OC3D] Customer Care Forums > Asus UK Customer Care Forums
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-05-20, 11:21 PM
SparkleDJackson's Avatar
SparkleDJackson SparkleDJackson is offline
OC3D Elite
 
Join Date: Jan 2011
Location: northern ireland
Posts: 1,954
rampage v edition 10 usb issues

turns out my keyboard is fecked as its doing the same disconnecty thing.

__________________
6900k, Evga RTX 2080 ti watercooled w/backplate
64GB Corsair Dominator Platinum 3200, Rampage V Edition 10
Corsair 900D.
Reply With Quote
  #2  
Old 11-05-20, 05:12 AM
looz's Avatar
looz looz is offline
OC3D Elite
 
Join Date: Feb 2013
Location: Finland
Posts: 1,756
The way you describe it sounds indeed like a hardware issue, but I'd try installing drivers just in case windows update installed a broken revision or something similar.


https://www.asus.com/fi/Motherboards...Desk_Download/ there's a USB driver further down.


But in case it's the controller, USB 3.0 PCI-E cards are a decent option, though if you still have 780 SC SLI, it's possibly going to be a compromise in PCI-E lanes and GPU airflow... For example: https://www.amazon.co.uk/FebSmart-Se...dp/B07MZ3Q5KQ/


You could also try splitting the USB-C ports, but might be the same controller, I am not sure on that. Maybe your phone came with a USB-C to USB adapter so you could try out its function.
__________________
i7 8700k - 16GB - 2060 FE - 660p 1TB + MX500 2TB - HE-4XX w/ Topping D30+A30
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 08:16 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.