Go Back   OC3D Forums > [OC3D] Graphics & Displays > Graphics Cards
Reply
 
Thread Tools Display Modes
 
  #61  
Old 18-08-14, 12:02 PM
Warchild Warchild is offline
OC3D Elite
 
Join Date: Feb 2013
Location: Norway, Oslo
Posts: 5,495
Quote:
Originally Posted by SuB View Post
lol, joined, necro'd and told a lot of well informed people that they're giving bad advice. Way to make an introduction.

Rubbing / isopropyl alcohol has been a recommended product for this kind of thing for quite literally, years. It's nice that you're well informed of it's contents, but I've yet to run into anyone that's had an issue.

Personally for cleaning things now I use the Articlean stuff because it's absolutely amazing, and it smells nice!
Also felt the need to post this link on another forum mocking the OP and all those in it.

Reply With Quote
  #62  
Old 18-08-14, 12:26 PM
barnsley's Avatar
barnsley barnsley is offline
born in a.....
 
Join Date: Dec 2012
Location: Cambridge
Posts: 7,216
Quote:
Originally Posted by Warchild View Post
Also felt the need to post this link on another forum mocking the OP and all those in it.
Hope he gets put in his place for having his head that far up his own arse.
__________________
Rig: i7 [email protected]|2x8gb HyperX Fury|Intel z97-AR|Corsair H75| 2x Nvidia 1070 founders edition|Superflower leadex 750W gold|Inwin 904| 970 EVO 500GB m.2|512GB evo 840| Crucial MX 500 500GB|ASUS MG279Q +Acer S240HL| Windows 10 pro, 8.1 pro| Kubuntu LTS
Audio: Silverstone EB01-E+EB03+DT 770 Pro 250Ω+Samson SAGOMIC
Ducky Legend (cherry red)+Zowie AM-FG
Reply With Quote
  #63  
Old 18-08-14, 01:04 PM
tinytomlogan's Avatar
tinytomlogan tinytomlogan is offline
The Guvnor
 
Join Date: Dec 2007
Location: TTL Towers
Posts: 20,964
I just rub mine with icecubes and sprinkle salt and sugar on afterwards. If that doesnt work it goes in the washing machine on a boil wash with some vanish and a bit of bleach.
__________________
If you recommend a product LINK THE REVIEW


Get along or run along. Your choice
Reply With Quote
  #64  
Old 18-08-14, 01:06 PM
MadShadow MadShadow is offline
OC3D Elite
 
Join Date: Nov 2013
Location: St Andrews, Scotland
Posts: 3,282
Quote:
Originally Posted by tinytomlogan View Post
I just rub mine with icecubes and sprinkle salt and sugar on afterwards. If that doesnt work it goes in the washing machine on a boil wash with some vanish and a bit of bleach.
Just be sure not to put AMD CPUs in the washing machine, they go in the dish washer. You dont want to bend those pins!
__________________
|i5 4460|8GB RAM|R9 380 4GB|ASUS Z97-I Plus|WD Blue 1TB|Corsair RM650|Phanteks Enthoo EVOLV ITX|


Reply With Quote
  #65  
Old 18-08-14, 01:08 PM
Wraith's Avatar
Wraith Wraith is offline
Bettyswollocks
 
Join Date: Jun 2013
Location: On the Moon.
Posts: 7,620
Quote:
Originally Posted by tinytomlogan View Post
I just rub mine with icecubes and sprinkle salt and sugar on afterwards. If that doesnt work it goes in the washing machine on a boil wash with some vanish and a bit of bleach.
+9999 for this!


If you are however visiting from an external source please DON'T try this at home, it may void your warranty.
__________________
“A person who never made a mistake never tried anything new.” ~ Albert Einstein
Reply With Quote
  #66  
Old 18-08-14, 01:09 PM
barnsley's Avatar
barnsley barnsley is offline
born in a.....
 
Join Date: Dec 2012
Location: Cambridge
Posts: 7,216
Quote:
Originally Posted by MaddenShadow View Post
Just be sure not to put AMD CPUs in the washing machine, they go in the dish washer. You dont want to bend those pins!
If you bend them you can just replace them with drawer pins though so dw
__________________
Rig: i7 [email protected]|2x8gb HyperX Fury|Intel z97-AR|Corsair H75| 2x Nvidia 1070 founders edition|Superflower leadex 750W gold|Inwin 904| 970 EVO 500GB m.2|512GB evo 840| Crucial MX 500 500GB|ASUS MG279Q +Acer S240HL| Windows 10 pro, 8.1 pro| Kubuntu LTS
Audio: Silverstone EB01-E+EB03+DT 770 Pro 250Ω+Samson SAGOMIC
Ducky Legend (cherry red)+Zowie AM-FG
Reply With Quote
  #67  
Old 18-08-14, 01:11 PM
Damien c Damien c is offline
OC3D Elite
 
Join Date: Feb 2012
Location: North West UK
Posts: 1,441
I generally don't use stuff like this as the thermal paste is never on the chip long enough, to dry out as I normally end up messing with the cooler etc every couple of months.

If I had to remove almost dry thermal paste such as that, that is on a gpu if I go to watercool it then I will use something like Articlean and I just make sure I dry the cpu or gpu even after using that stuff.
__________________
Reply With Quote
  #68  
Old 18-08-14, 01:36 PM
RizeAllard RizeAllard is offline
Advanced Member
 
Join Date: Feb 2011
Location: Budapest, Hungary
Posts: 290
Quote:
Originally Posted by Damien c View Post
I generally don't use stuff like this as the thermal paste is never on the chip long enough, to dry out as I normally end up messing with the cooler etc every couple of months.

If I had to remove almost dry thermal paste such as that, that is on a gpu if I go to watercool it then I will use something like Articlean and I just make sure I dry the cpu or gpu even after using that stuff.
I always use isopropyl alcohol for cleaning TIM. I just using a dry (paper towel) clothes for wipe it down. I had never get in trouble with it. Its good because if it remains on some stuff it will completly evaporated in some minutes. I think the litle black ruber he has removed coused the problem because the water block (as it was applied in a wrong way) could couse a
short circuit on the small capacitors or resistors next to gpu.
__________________
Intel i7-5930K/\Gigabyte X99-UD7 WiFi/\Kingston HyperX Predator DDR4-2666MHz 16GB kit CL13/\2× Gigabyte R9-290X 4GB DDR5 + EKWB Full Cover + Blackplate/\Samsung SP961 m.2 1TB SSD/\WD Green 3TB/\3×WD 2TB Caviar Green/\2×Seagae Barracuda 1TB 7200.10/\Corsair AX1200i/\XSPC H2O 750 with Alpha Cool 240mm RAD + EK Waterblocks XT240 rad + EK Supreme HF + EKWB 290X FullCover block + Hardtubes.


Reply With Quote
  #69  
Old 18-08-14, 01:45 PM
SuB's Avatar
SuB SuB is offline
The Webmaster
 
Join Date: Jul 2005
Location: Taking a break
Posts: 8,717
Quote:
Originally Posted by barnsley View Post
The lemonish stuff? I love it too!
yeah can't believe I'd never used it before when I nekkid'ified my 780's I'll never go back, amazing stuff

Quote:
Originally Posted by Warchild View Post
Also felt the need to post this link on another forum mocking the OP and all those in it.
Oh? did i miss something?


Quote:
Originally Posted by RizeAllard View Post
I always use isopropyl alcohol for cleaning TIM. I just using a dry (paper towel) clothes for wipe it down. I had never get in trouble with it. Its good because if it remains on some stuff it will completly evaporated in some minutes. I think the litle black ruber he has removed coused the problem because the water block (as it was applied in a wrong way) could couse a
short circuit on the small capacitors or resistors next to gpu.
Read up bud, the thread got necro'd thanks for the contribution though...
__________________
Gigabyte Z390 Aorus Pro | i7-8700k | 32GB Corsair Vengeance 3000Mhz DDR4 | nVidia RTX 2080Ti | Creative Audigy Rx | 1Tb Samsung 970 EVO+ M.2 | 1TB Samsung 860 QVO | 2TB Seagate Barracuda | Corsair RM850 | Fractal Define S | Noctua NH-U14S | Roccat Kone Optical - Navy Storm | QPad MK85 Pro w/ Cherry Red MX | DELL U2413 + 2 x U2412M | AKG K702's | AKG K7XX S/N#000016 | Beyerdynamic DT770 Pro 250Ohm | TM Hotas Warthog Stick and Throttle | Saitek Combat Pro Pedals | TrackIR 5 | TrackClip Pro

Notice: Don't feed the trolls!
Reply With Quote
  #70  
Old 18-08-14, 02:01 PM
barnsley's Avatar
barnsley barnsley is offline
born in a.....
 
Join Date: Dec 2012
Location: Cambridge
Posts: 7,216
Quote:
Originally Posted by SuB View Post
yeah can't believe I'd never used it before when I nekkid'ified my 780's I'll never go back, amazing stuff
Its saved a motherboard that got thermal paste in the socket. Basically its the cure to stupidity. A delicious wiff of lemon and intelligence.
__________________
Rig: i7 [email protected]|2x8gb HyperX Fury|Intel z97-AR|Corsair H75| 2x Nvidia 1070 founders edition|Superflower leadex 750W gold|Inwin 904| 970 EVO 500GB m.2|512GB evo 840| Crucial MX 500 500GB|ASUS MG279Q +Acer S240HL| Windows 10 pro, 8.1 pro| Kubuntu LTS
Audio: Silverstone EB01-E+EB03+DT 770 Pro 250Ω+Samson SAGOMIC
Ducky Legend (cherry red)+Zowie AM-FG
Reply With Quote
Reply

Tags
evga, g10, gtx, nvidia, nzxt

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 12:40 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.