Go Back   OC3D Forums > [OC3D] Customer Care Forums > Corsair Customer Care Forum
Reply
 
Thread Tools Display Modes
 
  #21  
Old 25-06-15, 06:53 PM
Dicehunter's Avatar
Dicehunter Dicehunter is offline
Resident Newb
 
Join Date: Oct 2012
Location: Newbsville
Posts: 13,456
Quote:
Originally Posted by TPC View Post
Money?
Reliability.

I remember one of the top overclocking guys stating he wouldn't touch a Corsair PSU for a world record benching session due to reliability.

And the amount of people who I personally know who's Corsair PSU's have gone funky is alarmingly high.

I'm sure the slightly newer ones are good but I have no reason to change it, It looks awesome and performs flawlessly

__________________
- Intel Core i9 9900K @ 5GHz - Asus ROG Max XI Hero -
- Corsair Vengeance Pro RGB 4x8GB @ 3600MHz -
- WD Black SN750 1TB - RTX 2080 Ti @ 2000/7500 -
- Windows 10 Pro 64 Bit Edition - Corsair 680X Black -
Reply With Quote
  #22  
Old 25-06-15, 09:27 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
Quote:
Originally Posted by Dice Hunter View Post
Not forgetting to mention DEM LOOKS !!!

Alright, I'll give you that
Reply With Quote
  #23  
Old 25-06-15, 11:02 PM
Dicehunter's Avatar
Dicehunter Dicehunter is offline
Resident Newb
 
Join Date: Oct 2012
Location: Newbsville
Posts: 13,456
Hey Grey_beard do you know if the H80i GT will be compatible with the HG10 by chance ?

I'm asking as I'd like the rads and hoses on both the AIO's *H100i GTX + H80i GT* To match, Plus I could give the Titan X some green underglow
__________________
- Intel Core i9 9900K @ 5GHz - Asus ROG Max XI Hero -
- Corsair Vengeance Pro RGB 4x8GB @ 3600MHz -
- WD Black SN750 1TB - RTX 2080 Ti @ 2000/7500 -
- Windows 10 Pro 64 Bit Edition - Corsair 680X Black -
Reply With Quote
  #24  
Old 25-06-15, 11:06 PM
Tolemac's Avatar
Tolemac Tolemac is offline
OC3D Elite
 
Join Date: Aug 2014
Location: Bonkersville.UK
Posts: 2,486
Quote:
Originally Posted by Dice Hunter View Post
Performance wise there's not much between them plus there's a reason all the top overclockers use Superflower

Not forgetting to mention DEM LOOKS !!!

you have gotta love that look I see it everyday
__________________

Build Log: http://forum.overclock3d.net/showthread.php?t=72241

“If you knew the magnificence of the three, six and nine, you would have a key to the universe.” – Nikola Tesla

Reply With Quote
  #25  
Old 26-06-15, 05:47 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
Quote:
Originally Posted by Dice Hunter View Post
Hey Grey_beard do you know if the H80i GT will be compatible with the HG10 by chance ?

I'm asking as I'd like the rads and hoses on both the AIO's *H100i GTX + H80i GT* To match, Plus I could give the Titan X some green underglow
Yup, HG10 is going to be compatible with H80i GT.

Read my PM yet?
Reply With Quote
  #26  
Old 26-06-15, 11:39 PM
Dicehunter's Avatar
Dicehunter Dicehunter is offline
Resident Newb
 
Join Date: Oct 2012
Location: Newbsville
Posts: 13,456
Quote:
Originally Posted by Grey_beard View Post
Yup, HG10 is going to be compatible with H80i GT.

Read my PM yet?
You'll need to send it again bud
__________________
- Intel Core i9 9900K @ 5GHz - Asus ROG Max XI Hero -
- Corsair Vengeance Pro RGB 4x8GB @ 3600MHz -
- WD Black SN750 1TB - RTX 2080 Ti @ 2000/7500 -
- Windows 10 Pro 64 Bit Edition - Corsair 680X Black -
Reply With Quote
  #27  
Old 27-06-15, 12:18 AM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
That's really weird, I really thought I sent it.. I just sent it again.
Reply With Quote
  #28  
Old 27-06-15, 02:07 AM
Dicehunter's Avatar
Dicehunter Dicehunter is offline
Resident Newb
 
Join Date: Oct 2012
Location: Newbsville
Posts: 13,456
Quote:
Originally Posted by Grey_beard View Post
That's really weird, I really thought I sent it.. I just sent it again.
Read and replied
__________________
- Intel Core i9 9900K @ 5GHz - Asus ROG Max XI Hero -
- Corsair Vengeance Pro RGB 4x8GB @ 3600MHz -
- WD Black SN750 1TB - RTX 2080 Ti @ 2000/7500 -
- Windows 10 Pro 64 Bit Edition - Corsair 680X Black -
Reply With Quote
  #29  
Old 29-06-15, 06:22 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,076
Quote:
Originally Posted by Dice Hunter View Post
Read and replied
Alright cool. We'll just take it from there.
Reply With Quote
  #30  
Old 30-06-15, 10:46 AM
Dicehunter's Avatar
Dicehunter Dicehunter is offline
Resident Newb
 
Join Date: Oct 2012
Location: Newbsville
Posts: 13,456
My H110i GT got delivered from OCUK today, Just have to wait for the HG10 to be released and it will be used with an H100i on my Titan X.

240mm rad just for GPU cooling





Shame the link software sucks though, Fans don't show up in Corsair link and neither does the logo colour changer.

Had the same problem with my H80, H100, H100i and now my H110i GT.

*EDIT*

Ok fixed, I did a quick windows re-install and that seems to have cured it for now, This happens with every new Corsair link release, No clue why
__________________
- Intel Core i9 9900K @ 5GHz - Asus ROG Max XI Hero -
- Corsair Vengeance Pro RGB 4x8GB @ 3600MHz -
- WD Black SN750 1TB - RTX 2080 Ti @ 2000/7500 -
- Windows 10 Pro 64 Bit Edition - Corsair 680X Black -
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 12:34 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.