Go Back   OC3D Forums > [OC3D] Customer Care Forums > Corsair Customer Care Forum
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-04-19, 05:27 PM
FTLN FTLN is offline
OC3D Elite
 
Join Date: Feb 2012
Location: France
Posts: 1,492
Corsair RM750i cannot handle a 2080ti

Hi Peeps & Corsair,

Just thought I'd make a post letting you know that the RM750i cannot handle a 2080ti with a slight overclock in my system. Short benchmarks are fine but after 10 to 15 minutes or so of GPU intensive games my system just reboots. I put back in my old and trustworthy AX760i and I get no issues at all in the same games and also temps seem to be close to 20c lower on the GPU (low 60s instead of Low 80s).

I RMA'd the RM750i also and received a brand new one, PC still reboots after about 10-15 mintues gaming.

Setup is Maximus X Hero, 9900k @5ghz, 65gb 3000mhz Corsair LED, H115i, 2080ti Aorus Extreme with +100 core and +1000 memory.

If you have any comments or feel that both PSU's could have been defective please feel free to let me know.


Cheers, FTLN

__________________
Intel Core i9 9900kK @ 5.00GHz @1.275v - Asus ROG Maximus Hero - Corsair 3000mhz CL16 LED 4x16GB SKHYNIX - Thermal Take View Glass - PM961 1TB x 2 RAID0 - Nvidia GTX 1080 Ti - Corsair H110i - Corsair Commander Pro - Asus ROG Swift PG279Q 2560x1440P G-Sync 165Hz
Reply With Quote
  #2  
Old 11-04-19, 10:37 AM
Thanos Thanos is offline
Newbie
 
Join Date: Apr 2019
Posts: 23
Curious, did you try changing from the default multiple +12V rails mode to single +12V rail mode to see if it made a difference?
Reply With Quote
  #3  
Old 12-04-19, 07:13 AM
FTLN FTLN is offline
OC3D Elite
 
Join Date: Feb 2012
Location: France
Posts: 1,492
Yep , tried both single rail and multi and with both PSU's (original RM750 & the new recevied via the RMA) , both cannot handle the overclock on the 2080 ti.. The AX760i has no issues.
__________________
Intel Core i9 9900kK @ 5.00GHz @1.275v - Asus ROG Maximus Hero - Corsair 3000mhz CL16 LED 4x16GB SKHYNIX - Thermal Take View Glass - PM961 1TB x 2 RAID0 - Nvidia GTX 1080 Ti - Corsair H110i - Corsair Commander Pro - Asus ROG Swift PG279Q 2560x1440P G-Sync 165Hz
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 07:41 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.