Go Back   OC3D Forums > [OC3D] Customer Care Forums > Corsair Customer Care Forum
Reply
 
Thread Tools Display Modes
 
  #51  
Old 09-05-16, 11:44 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,075
Thanks for sharing that Chroma.... It must have been a glitch while you're doing the FW update. I'm just glad that it all worked out in the end

Just a heads up though for holding both buttons before plugging in the mouse - that's exactly how do you to hard FW reset. I wouldn't really recommend it until it's suggested by our tech support, as that procedure could potentially brick a unit...

Reply With Quote
  #52  
Old 23-05-16, 08:32 PM
Avro Avro is offline
Member
 
Join Date: Mar 2012
Location: London / Southampton
Posts: 137
Thought I'd piggyback this thread. Got an M65 which is a month out of warranty as is typical for developing issues.
Basically the mouse will stop moving but all the buttons work and will need to be unplugged and plugged back in. The firmware says 2.12 although I've seen others mention 2.26 but I can't find anywhere to update the firmware.
Reply With Quote
  #53  
Old 11-08-16, 04:26 AM
darkfyre darkfyre is offline
Newbie
 
Join Date: Aug 2016
Posts: 1
Talking

Quote:
Originally Posted by Chroma72 View Post
I had the same problem. Unboxed the mouse, plugged it in. Had to move it around a couple of USB ports to get it to work initially. The LED light was yellow. I installed the utility software from the Corsair site. Everything was cool. A box popped up saying there was an updated version of the M65 firm ware. I clicked install. Then the mouse LED turned a bluish color and the mouse stopped working and the light started blinking. I rebooted, moved the mouse to different USB ports...nothing worked. All I would get is a non-working mouse and a blinking LED.

Then on a whim, with the computer on I unplugged the mouse from the USB port, held down the Left and Right mouse buttons and plugged it back in. BAM! It works now.

Hope this helps someone.

-Chroma
I joined just to respond to this:
THIS FIXED MY MOUSE
Thank you, and spread the word!

Can't remember how long I've had this mouse, since 2012 I think.
Never an issue until earlier, except sometimes on linux boot.
But mouse responded odd earlier, then just blinky blink.
Tried all ports, and PC restart.

Holding both left and right mouse while plugging in, fixed me right up.
Reply With Quote
  #54  
Old 16-08-16, 08:57 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,075
Quote:
Originally Posted by darkfyre View Post
Holding both left and right mouse while plugging in, fixed me right up.
Nice! glad to hear that trick worked out for you
Reply With Quote
  #55  
Old 28-08-16, 12:12 AM
Xisiqomelir Xisiqomelir is offline
Newbie
 
Join Date: Sep 2015
Posts: 5
Hey Grey, just got my RMA'd M65 in from Hong Kong, working perfectly.

Thanks for helping me out with my ticket!
Reply With Quote
  #56  
Old 30-08-16, 06:18 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,075
Quote:
Originally Posted by Xisiqomelir View Post
Hey Grey, just got my RMA'd M65 in from Hong Kong, working perfectly.

Thanks for helping me out with my ticket!
Sweet! nice to hear that man

Let me know if you run into any issues with any of our hardware.
Reply With Quote
  #57  
Old 16-05-17, 10:59 AM
ChinaEmporer ChinaEmporer is offline
Newbie
 
Join Date: May 2017
Posts: 1
Corsair M65 Vengeance stopped working

Hi Grey Beard, I wondered if you could help me with this?

I have been experiencing issues with my mouse. One morning I turned my PC on and the mouse started flashing. I've tried everything to fix it (firmware update) but windows will not recognise my mouse as a device.

I have submitted a ticket #6929298.

Your assistance in this matter would be greatly appreciated.
Reply With Quote
  #58  
Old 16-06-17, 08:09 PM
Grey_beard's Avatar
Grey_beard Grey_beard is offline
OC3D Elite
 
Join Date: May 2013
Location: Corsair HQ
Posts: 1,075
Hey China, This is already a super late reply bu I just wanted to double check on this so I asked our RMA and see if it's been sorted out. Looks like your RMA has already been resolved.
Reply With Quote
  #59  
Old 02-10-17, 07:36 AM
Xisiqomelir Xisiqomelir is offline
Newbie
 
Join Date: Sep 2015
Posts: 5
Hi Grey, the M65 has picked up a worrying triple-or-more-clicks per one left click issue.

I'm also not entirely certain but I might have just gone past my 2 year warranty.

Can I put a ticket in? If I'm out-of-warranty what is the procedure?
Reply With Quote
  #60  
Old 10-10-17, 11:28 PM
Corsair Nick Corsair Nick is offline
Corsair Rep
 
Join Date: Jul 2017
Posts: 4
Xisiqomelir I would go ahead and put in a ticket, and one of the Technical Support reps will be able to provide you some options.
Reply With Quote
Reply

Tags
borken, corsair, faulty, m65, rma

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump










All times are GMT. The time now is 05:25 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.