Go Back   Overclock3D Forums > [OC3D] Graphics & Displays > Graphics Cards
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-12-09, 01:54 PM
GavX GavX is offline
OC3D Crew
 
Join Date: Mar 2008
Posts: 778
Dead 4870?

So, i get in from a "hard" day at college, fire up red october... and it turns on, just nothing on the screen.

Was working damn fine last time, so I am stumped.

I tested with another monitor, the one I am on now, and still nothing on the screen.

Weird thing is, you can hear it go to the welcome screen, and I can log in, I just can't see anything at all. Ideas? I don't even see POST

__________________
Fail Hard, Fail Often!
Reply With Quote
  #2  
Old 04-12-09, 02:03 PM
Youngie1337 Youngie1337 is offline
OC3D Elite
 
Join Date: Feb 2008
Location: Rugby
Posts: 2,625
Quote:
Originally Posted by name='GavX'
So, i get in from a "hard" day at college, fire up red october... and it turns on, just nothing on the screen.

Was working damn fine last time, so I am stumped.

I tested with another monitor, the one I am on now, and still nothing on the screen.

Weird thing is, you can hear it go to the welcome screen, and I can log in, I just can't see anything at all. Ideas? I don't even see POST
Have you tried removing the card?
Reply With Quote
  #3  
Old 04-12-09, 02:25 PM
GavX GavX is offline
OC3D Crew
 
Join Date: Mar 2008
Posts: 778
gonna be a tough job, watercooled that PC to the teeth, and currently don't have a second card, servers onboard but I can ask my flatmate for a 4670 I am sure, but not tonight, for tonight, we dine in hell! Or, at my Mums, so wont see him tonight
__________________
Fail Hard, Fail Often!
Reply With Quote
  #4  
Old 07-12-09, 12:08 PM
GavX GavX is offline
OC3D Crew
 
Join Date: Mar 2008
Posts: 778
Does PowerColor offer a 2 year warranty do you think?

I totally didn't void that warranty of course 20seconds after receiving the card and ripping the stock cooler off.

On that note, anyone have any spare memory thermal pads for a 4870...?

Gonna test a 4670 in it tonight, might even crossfire the 2 we have in the flat, just for poops and giggles.

Anyone else heard of a similar issue, as the PC works fine, or at least it thinks its working fine, posting and all.
__________________
Fail Hard, Fail Often!
Reply With Quote
  #5  
Old 10-12-09, 07:03 AM
Rastalovich's Avatar
Rastalovich Rastalovich is offline
OC3D Elite
 
Join Date: Aug 2006
Location: Testing hardware somewhere
Posts: 11,419
Almost always related to power getting to the card.

Other than being dead that is.

Even with a beefy psu, power distribution can be the key.
__________________


Reply With Quote
  #6  
Old 10-12-09, 10:28 AM
noobieocer noobieocer is offline
Advanced Member
 
Join Date: Dec 2008
Posts: 423
my asus 4870 dark knight died, it didnt even post or go to welcome on xp. just black black screen when i boot it up, but if i pull the power connectors off and then boot, it will display i dont have power connectors connected =/

just odd
__________________
Intel Core 2 Duo E2160@3.6GHz @ 1.7v, 72c load

MSI Neo2-FR Intel P35, Inno3D Nvidia 8800GT 512MB

4Gb OCZ PC2-8500 C5@ 1066MHz, Samsung F1 750GB

Antec 900, TRUE w/Yateloon 38mm
Reply With Quote
  #7  
Old 10-12-09, 09:31 PM
GavX GavX is offline
OC3D Crew
 
Join Date: Mar 2008
Posts: 778
hm... well, I went rather gung-ho and just bought another cheapo 4870 from PC World of all palces for £80. By my logic, it can still number crunch, so the new card can do the display nonsense, and I can just run Crossfire... surely that'll work! Failing that, RMA the 4870, sure Powercolor offered a 2 year warranty. Typically Ebuyers warranty ran out in October, so they won't touch it
__________________
Fail Hard, Fail Often!
Reply With Quote
  #8  
Old 11-12-09, 08:09 PM
GavX GavX is offline
OC3D Crew
 
Join Date: Mar 2008
Posts: 778
threw a second 4870 in the second pcie, and nothing displayed, with the primary 4870 lifted out the second card worked fine in the second pcie slot, so gpu issues or mobo. Gonna put another card in the primary to check the pcie late still works, getting there I think
__________________
Fail Hard, Fail Often!
Reply With Quote
  #9  
Old 11-12-09, 08:13 PM
Brooksie's Avatar
Brooksie Brooksie is offline
OC3D Elite
 
Join Date: Jul 2007
Location: Aldershot, England
Posts: 3,712
good luck
__________________
3770k @ 4.5GHz | MSI Z77-GD65 |16GB Corsair Vengeance LP | MSI GTX670 Power Edition | Corsair AX850
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump






All times are GMT. The time now is 01:19 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.